Maximale Anzahl Datenpunkte Palamoa Graph



  • Guten Tag

    Ich kriege es nicht hin, auf Palamoa einen Graphen für eine ganze Woche zu erstellen.
    Wie viele Punkte kann der Graph maximal darstellen? Hängt das auch mit dem Übemittlungs-Intervall (bei mir 5min) oder der Breite des Graphen zusammen?



  • Guten Tag Marco,

    Da hast du einen wunden Punkt getroffen.
    In der aktuellen Version ist die Anzahl der darstellbaren Datenpunkte auf 200 begrenzt.
    Da diese Begrenzung sich auf die Anzahl und nicht auf den Zeitraum bezieht, ist der darstellbare Zeitraum tatsächlich auch vom Übermittlungs-Intervall abhängig. (Je höher das Übermittlungs-Intervall, desto größer der Zeitraum, der sich mit der festen Anzahl an Datenpunkten darstellen lässt.)
    Die Breite des Graphen ist nicht ausschlaggebend.

    Grundsätzlich ist die Einstellung anhand der Anzahl der Datenpunkte ohnehin suboptimal.
    Eine größere Verbesserung des Graphen-Widgets, inklusive sinnvollerer Einstellmöglichkeiten (nach Zeitraum) ist aktuell in der Mache und wird nicht lange auf sich warten lassen.
    Für die Zwischenzeit werde ich das Limit von 200 Datenpunkten auf 5000 anheben.

    Ich danke dir wieder einmal vielmals für dein wertvolles Feedback!



  • Oh, das Update ist offenabr erfolgt! Vielen Dank.
    Jetzt konnte ich schön auf "1 Woche" umstellen und bekomme den Graph wunderbar mit Datumsangaben angezeigt!

    Ist es eigentlich Absicht, dass die Palamoa-App das Layout ignoriert und die "Stacked" Version anzeigt?

    Achja, noch ein Hinweis: Wenn ein Wert immer als "0" übertragen wird, wird er in der numerischen Anzeige auf Palamoa manchmal mit "-" angezeigt.



  • Ja genau. Sorry, ich habe vergessen das hier zu erwähnen.

    Ist es eigentlich Absicht, dass die Palamoa-App das Layout ignoriert und die "Stacked" Version anzeigt?

    Ja, das ist Absicht. Ziel war, die Lesbarkeit auf kleinen Bildschirmen zu erhöhen. Da die Grid-Ansicht potentiell sehr groß werden kann, müsste man dabei eventuell weit sowohl horizontal als auch vertikal scrollen am Smartphone.

    Wenn ein Wert immer als "0" übertragen wird, wird er in der numerischen Anzeige auf Palamoa manchmal mit "-" angezeigt.

    Danke, werde ich mir ansehen!



  • Vielleicht hilft es ja, wenn ich nen screenshot und meine config angebe:
    2021-01-18_07h37_46.png

    {
        "Luftdruck": 
        {
          "unit":     "hPa",
          "color":     "#2222F0",
          "label":     "Luftdruck",
          "value":     "978.6"
        },
        "Luftdruck_Status": 
        {
          "unit":     "Status",
          "color":     "#2222F0",
          "label":     "Luftdruck_Status",
          "value":     "0"
        },
        "Taupunkt": 
        {
          "unit":     "°C",
          "color":     "#e86161",
          "label":     "Taupunkt",
          "value":     "2.0"
        },
        "Taupunkt_Status": 
        {
          "unit":     "status",
          "color":     "#e86161",
          "label":     "Taupunkt_Status",
          "value":     "0"
        },
        "Temperatur": 
        {
          "unit":     "°C",
          "color":     "#5F8AFF",
          "label":     "Temperatur",
          "value":     "21.4"
        },
        "Temperatur_Status": 
        {
          "unit":     "Status",
          "color":     "#5F8AFF",
          "label":     "Temperatur_Status",
          "value":     "0"
        },
        "device_name":   "AEQsnsmtgthp",
        "rel_Luftfeuchte": 
        {
          "unit":     "%RH",
          "color":     "#32d08e",
          "label":     "rel_Luftfeuchte",
          "value":     "27.8"
        },
        "rel_Luftfeuchte_Status": 
        {
          "unit":     "Status",
          "color":     "#32d08e",
          "label":     "rel_Luftfeuchte_Status",
          "value":     "1"
        }
      }
    

    Das mit dem stacked Layout hat bei mir leider genau den umgekehrten Effekt auf einem Tablet im Querformat. Um die numerischen werte zu sehen muss man recht weit nach unten scrollen.



  • Achja, nachdem ich auf der Website in den Edit-Modus gewechselt und die Sensor-Konfiguration geöffnet hatte, werden die "0"-Werte korrekt angezeigt... Bin etwas verwirrt, aber vielleicht hilft euch die Information weiter.
    2021-01-18_07h42_23.png